Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 14, 2026 - 22:30 MST
Scheduled
Reinvent Reseller Partner,
Please be advised that Reinvent will be conducting scheduled maintenance during off-peak hours on September 14th, starting at 1030 PM MST until September 15th at 1:30 AM MST.
During this maintenance window, Reinvent will be performing the following: -Metaswitch cCFS Robocall Mitigation and STIR/SHAKEN maintenance testing
As we implement Robocall Mitigation and STIR/SHAKEN enhancements on our cCFS deployment, a small number of calls may experience increased post-dial delay or, in rare cases, may fail to complete during the maintenance period.
Thank you for your understanding as we continue to optimize our network for the best reliability and service. Please contact our Support line at 855.245.1433 or open an Info Request in ServiceNow if you require any further information.
Posted Sep 10, 2026 - 23:12 MST
This scheduled maintenance affected: Outbound Calling (Outbound National, Toll-Free).